FIRSTBase Portal Application Access

Incident Report for Kasasa

Monitoring

FYI Only: Status has been updated to monitoring as there is no active incident. Caching is due to Tuesday evening planned maintenance.
Posted Jul 23, 2026 - 09:53 CDT

Investigating

We're seeing an issue where some users get stuck on a loading/spinning screen when opening FIRSTBase Home at base.kasasaonline.com. 

This happens because the browser is holding onto an older cached version of the site. That outdated version tries to load files that no longer exist after the recent update, which causes the page to fail.  JavaScript (JS) files in particular are heavily cached by browsers and can be especially sticky.

Quick fixes to resolve:
1. Hard refresh the page (Ctrl+Shift+R on Windows / Cmd+Shift+R on Mac). 
2. Clear the site’s cache/data for FIRSTBase, or open it in an incognito/private window or separate browser.
3. If necessary, you can also try forcing a new load by using our older, alternate address: base.bancvue.com.
Posted Jul 23, 2026 - 09:53 CDT
This incident affects: FIRSTBranch, INMO, and FIRSTBase Portal.