Incident Update

Incident Report for Kasasa

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 15:46 CDT

Identified

We are still seeing an single issue carrying over from previously noted incident. Our engineers are currently addressing.
Posted Jun 24, 2025 - 14:25 CDT
This incident affected: FIRSTBranch.